apt-cache-ng을 이용하고 있다. R 패키지를 업그레이드 할 때 자주 오류가 발생한다. apt-cache-ng에서 이전 캐시를 가지고 있기 때문에 발생하는 문제라고 한다.
대략 다음 폴더의 내용을 삭제한다. 그러면 새롭게 갱신된다.
/var/cache/apt-cacher-ng/cloud.r-project.org/bin/linux/debian/bookworm-cran40
apt-cache-ng을 이용하고 있다. R 패키지를 업그레이드 할 때 자주 오류가 발생한다. apt-cache-ng에서 이전 캐시를 가지고 있기 때문에 발생하는 문제라고 한다.
대략 다음 폴더의 내용을 삭제한다. 그러면 새롭게 갱신된다.
/var/cache/apt-cacher-ng/cloud.r-project.org/bin/linux/debian/bookworm-cran40
docker run -d -p 3000:3000 --name=grafana \
-e "GF_SERVER_DOMAIN=sensor.welovedoctor.com" \
-e "GF_SERVER_ROOT_URL=https://sensor.welovedoctor.com/" \
-e "GF_PUBLIC_DASHBOARDS_ENABLED=true" \
--user "$(id -u)" \
--volume "/home/byun1114/grafana_data:/var/lib/grafana" \
--network work \
--restart always \
grafana/grafana-enterprise
컨테이너를 이용해서 grafana를 사용하고, public dashboard를 이용하려면 위와 같이 -e 옵션으로 환경 변수를 추가해 준다.
nginx 에서는 다음처럼 수정하면 된다.
server {
server_name sensor.welovedoctor.com;
listen 443 ssl http2;
include snippets/ssl-welovedoctor.conf;
location / {
proxy_pass http://sweet.home:3000/;
proxy_set_header Host $host;
proxy_set_header X-Real-IP $remote_addr;
proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
proxy_set_header X-Forwarded-Proto $scheme;
proxy_http_version 1.1;
proxy_set_header Upgrade $http_upgrade;
proxy_set_header Connection "upgrade";
}
}